Home > Gtk Runtime > Gtk Runtime 2.12

Gtk Runtime 2.12

You'll notice that it is still based on gtk+-2.16.6. See the Downloads section for details. 009-03-22 GTK+ Runtime installer has been updated to gtk+-2.16.0. admin You are not logged. If you want to develop/compile GTK+ applications for Win32, download the dev packages from Tor Lillqvist's pages (see the Links section).

It contains the Gtk+ runtime and the Gtk# assemblies which get registered into Global Assembly Cache. Everywhere! In the meantime, you may download the gtk2_prefs binary for gtk 2.10.x which will work well. Mono has its own GAC that is independent of the Microsoft .NET GAC. http://gtk-win.sourceforge.net/

gtk2-runtime-2.12.6-2008-02-02-ash.exe - GTK+ Runtime installer, based on gtk+-2.12.6, glib-2.14.5, atk-1.20.0, pango-1.18.4, cairo-1.4.14. You seem to have CSS turned off. GTK+ Preference Tool has been recompiled to fix a compatibility problem with GTK+ 2.12.5.

gtk2-runtime-2.22.0-2010-10-01-ash.exe - GTK+ Runtime installer, based on gtk+-2.22.0, glib-2.26.0-2, atk-1.32.0, pango-1.28.3, cairo-1.10.0.SHA1: 2c79ffa6d510ad852873b675e7a5515257de015b gtk2-runtime-2.16.6-2010-05-12-ash.exe - GTK+ Runtime installer, based on gtk+-2.16.6-2, glib-2.20.5, atk-1.28.0, pango-1.26.2, cairo-1.8.8-4.SHA1: 08533a63c5139cca2e17f2ef0feabe5037dba68eNote: This is the last stable gtk2-runtime-2.16.6-2010-02-21-ash.exe - GTK+ Runtime installer, based on gtk+-2.16.6-2, glib-2.20.5, atk-1.28.0, pango-1.26.2, cairo-1.8.8-4. However, since application packages containing libxml2 didn't bundle iconv because it was already present in GTK+ installers because of glib, we have to bundle the iconv library to maintain compatibility with The iconv library is no longer needed by glib, but it is used by libxml2 (libxml2 is not distributed with the installer).

GTK+ Preference Tool (aka "gtk2_prefs" or "GTK2 Theme Selector") is also hosted here and included into the installers. Thanks to Valerio Messina for the patch.GTK+ Themes installer has also been updated to include the Nimbus theme and theme engine. If the application is a 100% .NET, without using P/Invoke to call into Win32 functions or using some Windows-specific assemblies, the code will run out of the box on Unix and An updated Themes package will be available soon.

Please don't fill out this field. Also, gtk2-runtime-2.12.5-2008-01-20 is up. gtk2-themes-2008-01-21-win32_bin.zip - GTK+ themes and theme engines as a zip file. A lot of changes with this version: All engines are compiled against GTK+ 2.10.

Please enable it or use sftp or scp. https://www.gtk.org/download/linux.php Extract "lib" and "share" directories to GTK+ installation path to install.Compatible with GTK+ versions 2.10 through 2.16. No, thanks SourceForge Browse Enterprise Blog Deals Help Create Log In or Join Solution Centers Go Parallel Resources Newsletters Cloud Storage Providers Business VoIP Providers Call Center Providers Home BrowseDevelopmentDesktop EnvironmentGTK+ See the Downloads section for details. 2008-12-17 GTK+ Runtime installer has been updated to gtk+-2.14.6.

Please don't fill out this field. See the Downloads section for details. gtk2-runtime-2.16.0-2009-03-22-ash.exe - GTK+ Runtime installer, based on gtk+-2.16.0, glib-2.20.0, atk-1.24.0, pango-1.24.0, cairo-1.8.6. To find out how more about what GTK+ can do for you, visit our features page.

Note that starting with this version, DLLs which are not direct dependencies of GTK+ (but used to be in the past) are not installed by default anymore. Please don't fill out this field. They will be removed in the next major version. 2009-09-12 GTK+ Runtime installer has been updated to gtk+-2.16.6. About this site This site is Copyright © 2008-2012 Alexander Shaduri Menu Home & News Details Downloads Embedding GTK+ GTK+ Preference Tool SourceForge Project Links Contact Actions View

It fixes PATH corruption (happened when the original value was longer than 1024 bytes; use Unicode NSIS from now on). No, thanks GTK+ Download: GNU/Linux About Features Download Screenshots Documentation Development Support Download for GNU/Linux and Unix Requirements You will need to get the GLib, GObject-Introspection, Pango, Gdk-Pixbuf, ATK and GTK+ gtk2-runtime-2.16.6-2010-02-24-ash.exe - GTK+ Runtime installer, based on gtk+-2.16.6-2, glib-2.20.5, atk-1.28.0, pango-1.26.2, cairo-1.8.8-4.

Stable Release To build GTK+ 3.22, see the installation guide.

Note that this installer does not include any development libraries or headers. New engines have been added, existing ones updated, same thing with themes. Archived Files If the file you're looking for is not listed here, check SourceForge's File Area. The Gtk# installer for .NET can be downloaded from the Downloads page.

Extract "lib" and "share" directories to GTK+ installation path to install.Compatible with GTK+ versions 2.6 through 2.16. gtk2-runtime-2.12.1-2007-10-28-ash.exe - GTK+ Runtime installer, based on gtk+-2.12.3, glib-2.14.4, atk-1.20.0, pango-1.18.3, cairo-1.4.10. Repository Browser If you prefer to view the git repository from your web browser for gtk+, glib, pango, gdk-pixbuf and atk. You seem to have CSS turned off.

GTK+ is written in C but has been designed from the ground up to support a wide range of languages, not only C/C++. Custom Packages (Non-Installer) gtk2-themes-2009-09-07-win32_bin.zip - GTK+ themes and theme engines as a zip file. Theme and theme-engine packages can also be found here, along with an utility to change GTK+ preferences. gtk2-runtime-2.12.5-2008-01-20-ash.exe - GTK+ Runtime installer, based on gtk+-2.12.5, glib-2.14.5, atk-1.20.0, pango-1.18.4, cairo-1.4.14.

gtk2-runtime-2.14.6-2008-12-17-ash.exe - GTK+ Runtime installer, based on gtk+-2.14.6, glib-2.18.3, atk-1.24.0, pango-1.22.2, cairo-1.8.0. Note that because of this change, your application may not be compatible with future versions of GTK+ Runtime. See the Downloads section for details. 2008-11-27 GTK+ Runtime installer has been updated to gtk+-2.14.5. Copyright © 2007-2016 The GTK+ Team | Valid XHTML and CSS GTK+ 2.12.12 package and runtime Library version 2.12.12 Devpak version 2.12.12 Packager GTKoolgtkool_2kx yahoo frHomepage Last modified 2008-06-21 15:39:59 Description

See the Downloads section for details. 2009-01-13 GTK+ Runtime installer has been updated to gtk+-2.14.7. Also, this installer still contains libjpeg-7.dll, libtiff-3.dll and libpng12-0.dll (see the previous news entry).